SP10/SP2x/SP3x Recovery sd-card/Boot sd-card creation instructions

Here are the instruction on creating recovery sd-card and boot sd-card to recover bricked SP10/SP30 miner in case your mmc image got broken. 
Before doing this, if your WebUI works - try returning the miner to factory settings from the settings tab. 

There are 2 types of images:

1) sd-boot image - for RUNNING from SD card, in case of physical problem with mmc. You will need to keep the SD in your miner forever.

2) sd-recovery image - for RECOVERING MMC from SD card. After this update you must remove SD card from miner, and reboot the miner.

Most clients will want the sd-recovery image.

!!! Never load SP10 image on SP3x/SP2x or other way around !!!

 

Instructions for Windows microSD Card creation for SP3x/2x:

You will need a micro-SD of at least 4GB and micro-SD-to-USB converter (card reader).

      1. Install Win32 Disk Imager .
      2. Download the sd-boot or recovery disk compressed image file from here ( sd-boot_image  / sd-recovery_image ) (120 MB).
      3. Extract the file from #2, and store it in a location of choice. (e.g. C:\Users\Public\bootsd.img - note it's a 2GB file)
      4. Insert an microSD Card - either formatted or blank - to the card reader. 
      5. Make sure that the card can be seen as a disk drive. (If it's not formatted, and windows pops-up a format request – you can dismiss it).
      6. Using Win32 Disk Imager write the image file (from step #3) onto the microSD card disk drive. This will put all the needed files on the microSD.
      7. Validate: Eject the microSD and insert it back in, ensure that you can see files (e.g. MLO , u-boot.img ) on the microSD.
      8. Now it can be used as a the miner working / recovery media.

skip to Instructions for SPXX miner recovery or Instructions for SPXX miner sd-boot.

    Instructions for Windows microSD Card creation for SP10:

    You will need a micro-SD of at least 4GB and micro-SD to USB converter (card reader).

        1. follow steps 1-7 from section Instructions for Windows microSD Card creation for SP3x/2x.
        2. Download the   SP10 image content file .
        3. Extract the spond_images_sp10.zip file. It will create folder named spond_images_sp10 with the required files.
          It has two folders - one for SD recovery and one for booting from SD. You probably need the recovery, unless your mmc is bad.
          Each folder has two folders inside - one for each partition of the SD card.
        4. Copy the files from the first partition to the SD-card. DON'T override the MLO file. Do override all other files. 
        5. Now it can be used as a the miner recovery media.
    skip to Instructions for SPXX miner recovery or Instructions for SPXX miner sd-boot.
          .

      Instructions for Linux microSD Card creation for SPXX:

      The commands here are for Ubuntu, but they can be done from any distribution with the relevant adjustments.
      Things to prepare:
        • MicroSD card of any size that you don't mind formatting
        • MicroSD to USB adapter
        • spond_images_spXX.zip file with the image (Downloadable from here SP10 or SP2x/SP3x)
      • cfdisk utility (sudo apt-get install cfdisk)
      • mkfs.xfs utility (sudo apt-get install xfsprogs)
      1) Open shell
      2) Execute "ls /dev | grep sd" to see what storage devices you have. 
      3) Insert SD card
      4) Execute "ls /dev | grep sd" to see what storage devices were added. Lets say it is /dev/sdx and  /dev/sdx1
      (if sdx1 was auto-mounted, un-mount it by executing "umount /media/<micro-sd-directory>")
      5) Execute "sudo cfdisk /dev/sdx"       // use your device here - be careful not to format main drive!!!
          - delete all partitions on sd-card
      - Create first partition (boot)
          - Create "new" -> "primary" partition of size 400MB from the "beginning" of the sd-card.
          - Mark it as "bootable"
          - Select type 0b (W95 FAT32)
       - Create second partition (config)
          - Create "new" -> "primary" partition of any size bigger then 1GB 
          - Select type 83 (Linux)
       - Select "write" and "quit" 
      6a) Execute "sudo mkdosfs /dev/sdx1"   // use your device here - be careful not to format your main drive!!!
      6b) Execute "sudo mkfs.xfs /dev/sdx2"   // use your device here - be careful not to format your main drive!!!
      7) Type "sync", remove and insert the sd-card from the USB slot and open the new partition 
      8) Open the spond_images_spXX.zip - it will create spond_images_spXX directory with the needed files. It has two folders - one for SD recovery and one for booting from SD. You probably need the recovery. Each folder has two folders inside - one for each partition.
      9) Copy the MLO file from the "1st partition" to the sd-card first partition (msdos) - this must be the first file you copy to the sd-card
      10) Copy the rest of the files from directory 1st-partition to the sd-card 1st partition, including sub-directories  (uImage, u-boot.img etc`)
      11) Copy the files from directory 2st-partition to the sd-card 2nd partition (can be empty)
      12) type `sync` and unmount your micro-sd
      skip to Instructions for SPXX miner recovery or Instructions for SPXX miner sd-boot.

      Instructions for SPXX miner recovery

      1) Insert the sd card to the sd slot in front of the miner machine
         SP10 - with the metal connector facing upwards.
         SP2x - with the metal connector facing upwards.
         SP3x - with metal connector facing down.
      2) Remove the power cord for 15 seconds and put it back in (especially important for SP35).
      3) Wait for 2 minutes (*both* lights in front of the machine will start to turn on/off *alternately* in a Christmas Tree like fasion -Green ... Yellow ... Green... Yellow... Green... Yellow... ............. ). 
      4) Remove the sd-card from the miner 
      5) Disconnect the power cord for 15 seconds and put it back in. 
      6) Once the system is up, do SW upgrade from the webUI and update your wallet and the pool.

      Instructions for SPXX miner sd-boot

      1) Insert the sd card to the sd slot in front of the miner
         SP10 - with the metal connector facing upwards.
         SP2x - with the metal connector facing upwards.
         SP3x - with metal connector facing down.
      2) Remove the power cord for 15 seconds and put it back in.
      If you want to reuse the micro-SD, you can reformat it with cfdisk on Linux to it's original size.
      Regards
      By Zvisha Shteingart | | important updates, recovery sdcard | 26 comments
      next post → ← previous post

      Comments

      • Dave - March 31, 2016

        I recently bought a sp35 it was working great them on day was hashing lik 206gh/s. I reboot it and now the sp35 boots up to main menu all shows runnging Except for cg miner and cg version is now N/A , miner gate is still runing pool address has never change. Wondering how i can install a new version of cgminer onto the sp 35 because no reboot or recovery is working. just wonder if I can load a cgminer program on and plug it in by usb or by sd card but something to give me a direction in stead of a dead end thanks..

      • Ladycrabs - March 21, 2016

        [b]И еще немного брендовой одежды[/b]

        [url=https://ad.admitad.com/g/eb8b7c12f0d03734167b780e165f0f/?i=5&ulp=https%3A%2F%2Ftopbrands.ru%2Fzhenskie-kollektsii%2Fodezhda%2Fplatya%2Fpovsednevnie-casual-platya%2F176166%2F]Купить Imago Платье 152523 или модные Imago Платье 152523 2016 бренда по цене 8000 RUR[/url]
        [url=https://ad.admitad.com/g/eb8b7c12f0d03734167b780e165f0f/?i=5&ulp=https%3A%2F%2Ftopbrands.ru%2Fzhenskie-kollektsii%2Fodezhda%2Fzhaketi-i-kardigani%2F181257%2F]Купить Imago Кардиган 151931 или модные Imago Кардиган 151931 2016 бренда по цене 8000 RUR[/url]
        [url=https://ad.admitad.com/g/eb8b7c12f0d03734167b780e165f0f/?i=5&ulp=https%3A%2F%2Ftopbrands.ru%2Fzhenskie-kollektsii%2Fodezhda%2Fplatya%2Fpovsednevnie-casual-platya%2F172526%2F]Купить Pompa Платье 147684 или модные Pompa Платье 147684 2016 бренда по цене 5900 RUR[/url]
        [url=https://ad.admitad.com/g/eb8b7c12f0d03734167b780e165f0f/?i=5&ulp=https%3A%2F%2Ftopbrands.ru%2Fzhenskie-kollektsii%2Fodezhda%2Fkurtki%2F175767%2F]Купить Izeta Кожаная куртка 151976 или модные Izeta Кожаная куртка 151976 2016 бренда по цене 25000 RUR[/url]
        [url=https://ad.admitad.com/g/eb8b7c12f0d03734167b780e165f0f/?i=5&ulp=https%3A%2F%2Ftopbrands.ru%2Fzhenskie-kollektsii%2Fodezhda%2Fpuhoviki-i-parki%2F175661%2F]Купить Woods Canada Пуховик с мехом 152258 или модные Woods Canada Пуховик с мехом 152258 2016 бренда по цене 56700 RUR[/url]

      • Chris - February 12, 2016

        For those having issues with their SP20s not booting up after a recovery flash. I was having the same issue on 4 of 6 of me. It would flash fine with the yellow green indicating it completed, but would not boot. What I figured out was if you put the recovery sd card back in then turn on the SP20, wait for the yellow light to come on then once it turns off pull out the sd card before it starts the recovery process and it will boot up. I was able to bring back all 4 non posting SP20s.

      • Nic - February 07, 2016

        Hi,

        I have an SP31 which has been down for many months now. I had been to busy to try & fix it but I can do so now. I have fully cleaned out the machine of dust, replaced 2 fans & checked it all over & nothing works.

        I have tried both the SP31 SD Recovery & Boot Disks & still nothing works at all.
        This is what happens when the machine is switched on. Both Power Supplies are working correctly.
        It starts, all fans work, Ethernet is connected but no Boot Up Yellow light Blinking, or Flashing or Anything!!

        When I use My Miner site on the net there is no detection of the miner being found anywhere on my system!!! This is incredibly annoying as I has the machine hashing at 4.8THS, or around, for at least 6 months working 24/7.

        Now it has been down for so long I do not know what to do. I have the serial cable but cannot get it to connect to either a desk top or laptop PC at all ??!! Do I need a specific software to use with my Windows based PC?

        I know this machine was built around Oct 2014, & used from Jan 2015 & stopped working July 2015. I tried so many things & gave up due to work etc.

        Now I want to get it working again & start mining at full power once more. Could it be the Management Board as I doubt both ASIC Boards could both be broken??

        Can anyone help or point me in the right direction? Is there a thread link to similar problems?

        Many thanks

      • chafis - January 06, 2016

        i need some help my ethernet port dos NOT turn off i already did the recovery and it is still the same. what can i do?

      • Jeff - December 30, 2015

        I am having the same issue but with a SP10
        Does anyone know how to fix this issue?

        My problem on my SP30 Yukon is that after setting up and trying different URL Pools is “Pool data successfully saved but failed to restart miner, please try again in 1 minute.” After restarting SP30 this is the other issue “There was a timeout performing the requested operation. It probably means CgMiner waits for the pool, check the state of CgMiner in the main page in a minute.” FYI, all the URL that I put was already running and still running with my ant miner. Please respond ASAP! I’m loosing profit, no! even if I can rergain 50% of my investment because I know this machine has no ROI!

        Thanks!

      • Mike - November 09, 2015

        Al, Joseph,
        I had the same issue for a while and found that there are 2 things that can affect the way the SP31 connects to a pool and at what speed.
        try checking to make certain your pool “MINING” URL is put into the pool field right (usually not the same as the public address.
        Speed: try setting Max Power Button down to 1050 to see if this will help. you can always increase it after it starts.
        Good luck and I hope they work.

      • Al - November 02, 2015

        Mitch Tikhman,
        i have a same problem. Were you able to solve this problem and how ?

      • Al - November 02, 2015

        Mitch Tikhman,
        i have a same problem. Were you able to solve this problem and how ?

      • joseph dalton - October 22, 2015

        my sp31 keeps restarting it hashes up to 2026gh and restarts and says waiting for pool connection. replaced the cat 6 cable, reseated the power packs, i upgraded and tried the downgrade software nothing unit keeps restarting the other units on the network are working fine.

        is there any help

      • Jeremy Humphrey - October 05, 2015

        I have a SP20 that worked and then didn’t. I am trying to do a recovery with no luck. Below is some info I posted on the Hashclub.org forum to give some info on what is going on. Perhaps you could lend some assistance. I would be very thankful if you could help.

        http://www.spondoolies-tech.com/blogs/technical-blog/13098521-sp10-sp2x-sp3x-recovery-sd-card-boot-sd-card-creation-instructions

        Here is a post of mine from this thread:

        https://hashclub.org/topic/862/spondoolies-sp20

        I would b happy if I could find a new controller for my SP20. I contacted Spondoolies about a new one and they wanted $150 plus shipping. I think that is rather steep and cant afford that. My Spondoolies SP20 was working good at one location. I shut it down, moved to another location and then it wouldn’t boot anymore. I really dont think the 2 hashing boards went bad. Perhaps I am wrong…….. But the controller wont boot or grab an IP addy no matter what I do. Tried the SD recovery as well as the SD boot……….

        Anyone happen to have a controller for an SP20? That would sell it to me for a reasonable price???? If I knew for sure that that it was the controller that went bad, I would buy the new one from Spondoolies but it is non refundable and I cant afford the gamble at the moment.

        When I was playing with the SP20 at this location it was working well. What I was attempting to do was to set up a wireless adapter for it using an Edimax usb wifi adapter plugged into the SP20’s usb port as per a tutorial I was following. Well, I plugged the wifi adapter in and booted up and using the web gui the option for wifi appeared. I configured the wifi and rebooted the unit. At first it wouldnt connect to the wifi so I rebooted it again. Then it connected and started hashing. I then shut down the SP20 once I confirmed it was hashing. Then I took it home and tried booting it up. The SP20 wouldnt connect to my network. so, I shut down the miner, removed the wifi adapter and connected the Ethernet wire. Still, it wouldnt show up on my network. I noticed the ethernet lights light up but the status light/s do nothing. The fan spins up on high and stays on high. The miner never pulls an IP address(I have used IP scanners to ensure). I also tried using the static address that I originally used with the unit when things were working properly before I tried using wifi(Damn I wish I had left it alone and never tried enabling wifi).

        I have a big question:

        If the hashing board/boards go bad should the controller still work and the Web GUI be Accessible?

        If nobody knows this answer, could you please direct me to someone who may be able to help answer my questions? I am just sick over this SP20 not working. I really want it to work again. I always took care of this miner. As I do with all y equipment. When I transported the SP20 it was securely placed in my trunk and I drive flat straight roads home which was 15 minutes away. In other words, not bumpy or windy roads.

        Thanx in advance for taking the time to read this post/thread.

      • rafael - October 04, 2015

        i can help i know how to do the recovery please send me mail to chafis_666@hotmail.com and i can explain to you step by step

      • Chris - September 30, 2015

        I have tried both and cannot get either to work for me either. SD-RECOVERY

      • jose lorenzo - August 11, 2015

        I have tried both the SD-Boot and Recovery and they do not work.

      • Matt - August 10, 2015

        I have tried both the SD-Boot and Recovery and they do not work. Please help.

      • Miguel Morales - August 04, 2015

        Hello, I have used the boot mode in a SP20. Now I cant start the SP20 without the microSD card, is there a way to modify boot to start it without the SD mard inside?

      • dave - July 15, 2015

        can anybody help me out, i have a sp31 dont boot or the recovery options doesnt work is there anyway to reset the system, now when i put the sp31 on the fans start real loud and no booting

      • Catalin - February 08, 2015

        My credentials won’t work on the UI interface. I tried to make a SD recovery , but to my surprise I found out that the SD slot is just a hole in the chasis … what do I do now? Not all SP20s have this SD slot for recovery?

      • Richard - February 02, 2015

        I didn’t had the correct password to login on my SP30, so the Spondoolies tech-support advised me to do a SD card recovery.
        This has solved the problem but left me with a new problem.

        After setting up i get the following message: “Pool data successfully saved but failed to restart miner, please try again in 1 minute.

        I’ve tried to restart the miner but keep getting the same message.
        Hope you can help me.
        Thanks for your help so far.

        Greetings Richard

      • Aaron - January 04, 2015

        I did this for both the recovery and boot options and neither worked! HELP!!!!

      • VorteXz - December 15, 2014

        Can I do it with just an USB stick for the SP20 ?
        the SP20 has an usb slot !

      • John Eric Tayco - November 15, 2014

        My problem on my SP30 Yukon is that after setting up and trying different URL Pools is “Pool data successfully saved but failed to restart miner, please try again in 1 minute.” After restarting SP30 this is the other issue “There was a timeout performing the requested operation. It probably means CgMiner waits for the pool, check the state of CgMiner in the main page in a minute.” FYI, all the URL that I put was already running and still running with my ant miner. Please respond ASAP! I’m loosing profit, no! even if I can rergain 50% of my investment because I know this machine has no ROI!

        Thanks!

      • edgar - November 09, 2014

        it worke don the sp30 – but the sp20 doesnt seem to want to know…

        what a ballache

      • Your Name - October 10, 2014

        Edgar – you have a dead unit. There’s nothing to lose. Do it.

      • edgar - September 11, 2014

        after waiting over an hour for a response to my initial dead rig, i found this..

        How do i know if this is what i need to do?

      • Mitch Tikhman - August 12, 2014

        I am having problem with accessing my SP10. It seems like it doesn’t see network/internet. I also have orange info light on when I turn it on. I tried to recover it with MicroSD card, but problem still remains. Any suggestions? It was working fine up until few days ago.

      Leave a comment

      Stay in Touch